読者です 読者をやめる 読者になる 読者になる

相殺する幸福と不幸の末路

同人ゲームシナリオライターの宣伝&オタ日記!


Windowsしか知らない男が中古のMACを買って困ったこと、悶絶したこと【appleなんて嫌いだ】

同人活動 同人活動-制作日記

スポンサーリンク



iphone版を制作するのにこんなに苦労があるなんて知らなかったよ…

読者のみなさま、ごきげんよー

同人サークル The sense of sightのBLACKGAMERです

 

自分の同人ゲームのiphone版を作るぞーということで意気込んだけれど、

新品を買うと10万~20万もする…

というわけで、採算がとれなさそうで安物のMACを購入したところ、

大後悔してるので書き記しておきます

 

 

買ったパソコンのスペック

MacBook (13-Inch Late 2006)

MAC OS X 10.6.8

CPU:2Ghz intel core 2 Duo

メモリ:2GB 667 Mhz DDDR2 SDRAM

お値段:18,000円

 

購入するときにはOSが大事だとも知らずに、

俺は低スペックでいいや…とこのパソコンを中古で買いました

だって、どうせ大したことしないし… 最新版じゃなきゃ困ることなんてないし…

 

うん、本当に後悔しているよ…

スペック or OSのバージョンによってインストール可否が決まるらしいんだ

 

つうか、MAC OS Xって書いてあったから安心してたよ

なんだよ、バージョン管理って…

みんなOS Xでlion とかyosemiteとかそんな名前があるなんて知らないよ…

 

XCODEをインストールしようとしてみた → できない

開発環境であるXCODEをダウンロードしようとしたら

エラーメッセージが出力されてダウンロード不可できませんでした

 

『このバージョンのos x 10.11はこのコンピュータにはインストールできません』

 

うん、日本語でOK?

何言ってるか分かんねえよ…と思いながら、いろいろググり始めました

 

dev.classmethod.jp

 

2015年2月から Xcode 6 以上が必要

先日 Apple からアナウンスがあったとおり、

2015年2月から Xcode 6 以上でビルドしたアプリしかサブミットできなく

なるのでご注意ください。

 

なお、アーキテクチャについても64ビットが必須になります。

64-bit and iOS 8 Requirements for New Apps | Apple Developer 

 

最低でも6以上が必要なのは分かったけれど、

過去分のインストールをするには最新の環境をいれる必要があるらしい…

 

で、肝心のインストールがエラーになる理由だけど、

エラーメッセージの後に書いてあるos x 10.11は、

どうにもOSが古いらしくて怒られているみたい…らしい?

というわけで、OSをアップグレードしてみることにしました

El Capitanをインストールしようとしてみた → できない

『このバージョンのos x 10.11はこのコンピュータにはインストールできません』

お前もか!? ふざけんなよ、マジで…

どうしようもねえじゃんかよ、なんなのこれ?

 

しかも、「もっと詳しく見る」ボタンを押しても無反応

いやいや、もっと詳しく教えてくれよ…頼むよ

 

主原因はパソコンがポンコツだから…

MacBook (13-Inch Late 2006)という生まれを見るに昔過ぎて耐えられないとのこと…

 

まーよく分からないけれど、とりあえず、一個前のOSとか探してみるかね

で、ググってみるとyosemite(ヨセミテ)がいいとのこと

んじゃ、それをインストールしてみます

yosemiteをインストールしようとしてみた → できない

ダウンロードに行ったけれど、app storeが表示されない

は? なんで? と思ってググってたらこんな話が…

detail.chiebukuro.yahoo.co.jp

 

OS X 10.10 Yosemiteは昨年の秋に提供開始されましたが、

今年10月1日のOS X 10.11 El Capitanの提供開始と同時に

Yosemiteの「新規のダウンロード」は終了しました。

 

1) YosemiteがプレインストールされていたMacのユーザ

2) 過去にYosemiteをダウンロードしたことがあるユーザ

  は、現在でもYosemiteをダウンロードできます。

 

ああーーーーーいやぁぁぁああああああああ!!!!  

待ってくれよ!? ほんと、待ってくれよ… なんなんだよ、イジメかよ

馬鹿じゃないの? こんなん絶対無理じゃない…

 

同じような被害者を発見するも役に立たない

apple コミュニティ:El Capitanにアップグレードできない

研究室のMac Pro-Z0LG(Mac OS X 10.7.5)を

El Capitanにアップグレードしようとすると

「このバージョンのOS X 10.11は,このコンピュータにはインストールできません.」

とメッセージが現れたのですが,どうすればよろしいでしょうか?

 

ちなみにこのMacには,Windows7がブートキャンプされています.

よろしくお願いします.

 

似てるような、そうでもないような…

その最後のアドバイスとして、こんなことが書かれてました

 

>もう一度、OS X 10.7.5Combo アップデータを当て直してみてはいかがでしょうか。

よし、それで探してみるか…

Lionの統合アップデートを入れてみる → できない

ダウンロードが始まったので、祈るような気持ちで1.91GBが落ちるまでを待ちます

つうか、その間も対策を探そうと思ったんだけどもう気力が続かなかったよ

 

で、落としてみると10.7にアップグレードしないと

これはインストールできないよ? とのこと

 

アップグレードなのかアップデートなのか分かりづらいんだよ、マジ勘弁してよ

 

apple コミュニティのosx 10.6.8から10.7にしたいという内容を見るに2000円とか払うらしい

で、払ったからと言って、上のレベルにアップグレードできる保証もなさそうな雰囲気

あーもーマジ無理、ほんと無理、なにこれレベル

 

このバージョンのos x 10.11はこのコンピュータにはインストールできません原因まとめ

あなたのパソコンは古すぎてOS X 10.11のインストールができない

だから、そのOSに耐えられないのならこのソフトいれられないよ! という意味みたいです

なので、何かソフトを落とそうとしてこのメッセージが出力されたら

そんなポンコツとはおさらばして新しいパソコンを買っちゃいなよ! という

上から目線のアドバイスをいただいたと思うのが正しいようです

 

知らない環境に飛び込むことは、Google先生と二人三脚をやることと同義だ

そして、転んでばっかりの俺はもう挫けそうだ

 

つうか、知らないってホントに辛いことなんだな…

実際、Windows触ってるからwindows7、windows8、windows10とか分かるけど

知らなかったらどれが何で、どこまで環境が耐えられるのか分からん

でも、windows7でも不自由なく開発できるからある程度昔のでも

行けそうな気もするが… うーん、勉強代でした

 

さて、安物買いの銭失いなこいつをどうしようか…

新しく買うのはやっぱり新品になるのか…

苦難な道はまだまだ続きそうですが、まずは返品可能か調べるところから始めます